custom controls for mouse

Errors and unexpected results
Post Reply
User avatar
joleenf
Posts: 1119
Joined: Mon Jan 19, 2009 7:16 pm

custom controls for mouse

Post by joleenf »

Hi,

Recently I tried to select the Google Earth setup in the User Preferences->Navigation Controls->Navigation Mode->Keyboard.

Then I tried to add a cursor readout for None:Middle mouse button.

However, the cursor readout setting does not work even though it appears to be set in the preferences. I also noticed that my mouse would rotate rather than translate when using shift left mouse button key.

Thanks,
Joleen
User avatar
bobc
Posts: 927
Joined: Mon Nov 15, 2010 5:57 pm

Re: custom controls for mouse

Post by bobc »

Hi Joleen -

I'm having a difficult time replicating this on Windows 7 or OS X using today's nightly. I found an old inquiry (Inquiry 464) where #3 in the Request looks to match what you are seeing, but this was from 2009 with a McV 1.0 beta 1 build. I have a few questions and tests that you can run that might give us some more information:

  1. You are using a nightly build, correct?
  2. What plugins do you have installed? I'm curious if a plugin's navigation settings could override what is in the User Preferences.
  3. Do you see this same behavior of the middle mouse button not giving probe output in all tabs/panels in your session?
  4. To see if there are any McV settings/preferences that might be causing the issue, could you try starting up a fresh session and see if you still have the problem. For example, you could start up McV with the -userpath flag with "./runMcV -userpath /Users/joleenf/NavControls". This will start up McV using the NavControls directory in place of your standard McIDAS-V directory. Can you try setting your navigation preferences in this session and see if the problem still occurs?

Thanks -
Bob
Post Reply