display conflict with joint image and wind barbs

Errors and unexpected results
Post Reply
User avatar
hproe
Posts: 499
Joined: Sat Nov 27, 2010 3:46 pm

display conflict with joint image and wind barbs

Post by hproe »

When I display an image band (typically from AVHRR) after having displayed a wind barbs (typically from ASCAT), I would expect the wind barbs to disappear under the image. But this is not so. The winds remain 'on top', save the flags (>50 units) - they disappear. Of course, the flags re-appear when I do View > Bring to Front.

This siutation is prone to mislead the user. With the wind barbs (partially) preserved, you may be led to believe that the wind field is on top and well displayed, which is only true as long as the wind speeds are <50 units. Good programming would call for the winds being covered completely by the image, wouldn't it?

cheers, HP
Attachments
intactFlags.png
eatenFlags.png
User avatar
bobc
Posts: 927
Joined: Mon Nov 15, 2010 5:57 pm

Re: display conflict with joint image and wind barbs

Post by bobc »

Hi HP -

The issue of only the flags of the wind barbs being covered up by the satellite image when working with ASCAT data is written up as Inquiry 2194.

I agree that there can be some confusion as to why the satellite display doesn't cover up the point data display. There's likely some kind of a priority system in the code that always wants to plot the point data on top of other layers. I've written up re-considering how this works as Inquiry 2440.

Thanks for reporting this -
Bob Carp
Post Reply