NetCDF subsetting problems

Errors and unexpected results
Post Reply
User avatar
kbedka1
Posts: 428
Joined: Wed Jan 28, 2009 7:27 pm

NetCDF subsetting problems

Post by kbedka1 »

I have a large NetCDF file that I've put on your ftp at pub/incoming/GOES_Overshooting_Cloud_Top_Detection_Daily_2007203.nc

See attached image, the data contained within this file is over the GOES-East and -West fields of view (65 N/S 179.9-30 W), but the domain in the region subsetting box in the lower right of the data chooser suggests that the data is off the map. I can only draw my subset box within the blue outlined domain that Mc-V has mistakenly interpreted from my file. The file is 4000x4000+ pixels x24 timesteps so I cannot display this dataset without subsetting. Could someone take a look at this and let me know what's going on? FYI, I'm using a nightly from Feb 1, 2016
Attachments
Screen Shot 2016-03-02 at 1.52.55 PM.png
User avatar
bobc
Posts: 927
Joined: Mon Nov 15, 2010 5:57 pm

Re: NetCDF subsetting problems

Post by bobc »

Hi Kris -

I'm replicating what you're seeing in the Region tab. I'm trying to look into what is going on, but I found a workaround. If you right-click and drag to the left a bit on the map, you can shift things around to the point where you can get the blue rubber band box over the actual domain of the data. An easy way to get the full domain once you are at this point is to use Ctrl+R. Alternatively, you can subset a smaller domain by clicking+dragging on the black squares on the outside of the blue rubber band box.

I'll update you on what I find with why this file doesn't work correctly in the Region tab of the Field Selector, but please let me know if the workaround of shifting the map doesn't work for you.
FieldSelector.jpg

Thanks -
Bob Carp

* post edited to add an image
User avatar
kbedka1
Posts: 428
Joined: Wed Jan 28, 2009 7:27 pm

Re: NetCDF subsetting problems

Post by kbedka1 »

This did work for me, thanks for the tip
User avatar
bobc
Posts: 927
Joined: Mon Nov 15, 2010 5:57 pm

Re: NetCDF subsetting problems

Post by bobc »

Hi Kris -

I'm glad that the workaround is working for you. I'm not able to figure out exactly what is going on with this file, so I wrote this up as Inquiry 2286. If you have any other questions/comments about working with this data, please let us know.

Thanks -
Bob
Post Reply