setLayerLabel Color

Errors and unexpected results
Post Reply
User avatar
joleenf
Posts: 1120
Joined: Mon Jan 19, 2009 7:16 pm

setLayerLabel Color

Post by joleenf »

Hi,

Is the setLayerLabel(color='Yellow') actually working in McIDAS-V 1.6? It does not seem to be working for me. If I use the jython shell, and type

Code: Select all

panel=buildWindow()
data = loadADDEImage(server='adde.ucar.edu', dataset='RTIMAGES', descriptor='GE-IR', size='ALL')
layer = panel[0].createLayer('Image Display', data)

layer.setLayerLabel('Test', color='green')

panel[0].captureImage('test.png')


'Test' is saving as white, my default...
test.png


If I then open the layer properties, I see that the color should have been green, which does get applied after the okay is selected.

Version: 1.6 beta1 Build-date: 2016-02-26 10:30

Thanks,
Joleen
User avatar
bobc
Posts: 938
Joined: Mon Nov 15, 2010 5:57 pm

Re: setLayerLabel Color

Post by bobc »

Hi Joleen -

Thanks for pointing this out, it is a definite bug. I wrote this up as Inquiry 2279.

As a workaround, for now you can use setLayerLabelColor(). For example:

Code: Select all

layer.setLayerLabelColor('green')

Thanks again -
Bob Carp
User avatar
bobc
Posts: 938
Joined: Mon Nov 15, 2010 5:57 pm

Re: setLayerLabel Color

Post by bobc »

Hi Joleen -

I just wanted to follow up with you on this and let you know that the color keyword of setLayerLabel is working in today's nightly. I've tested it across all platforms, but if you give it a look and see any problems please let me know.

Thanks -
Bob
Post Reply