inconsistent colour handling with wind barbs

Errors and unexpected results
Post Reply
User avatar
hproe
Posts: 503
Joined: Sat Nov 27, 2010 3:46 pm

inconsistent colour handling with wind barbs

Post by hproe »

Hi -

ASCAT netCDF files give wind speed in m/s. When displaying them as wind barbs, they are coded with the barbs reflecting counts in knots as expected. However, when applying a colour scale, the colours follow the default unit of m/s. To have the colouring match the the barbs, the 'colour unit' has to be explicitely changed to knots (Edit < Change Color Unit...). However,
when making the colour scale visible, the label showing the units still says 'm/s'. so, there are 2 isdsues:

1. I would expect that when displaying wind barbs, the unit used by the colour scale automaticaly matches the one used by the wind barb display type.
2. Changing unit through Edit > Change Color... does not apply this change to the unit label.

cheers, HP
User avatar
bobc
Posts: 933
Joined: Mon Nov 15, 2010 5:57 pm

Re: inconsistent colour handling with wind barbs

Post by bobc »

Hi HP -

Thanks for the bug reports. We believe that the first issue you mentioned is related to your changing wind barb display forum post. I added to Inquiry 1911 that we need to make sure that the Change Line Color defaults to the units of the data both initially and after projection changes.

The second issue is a bug that has not been reported to us before, but I'm able to replicate it both with ASCAT as well as standard GFS CONUS data. I wrote up a new inquiry for this, Inquiry 1925.

I'll keep you posted if there are any updates to the inquiries.

Thanks again -
Bob Carp
User avatar
hproe
Posts: 503
Joined: Sat Nov 27, 2010 3:46 pm

Re: inconsistent colour handling with wind barbs

Post by hproe »

Hi Bob -

Thanks for handling these issues. I am looking forward to see these bugs removed by 1.5stable. Just for completeness: the bugs are affecting also RAPIDSCAT (RSCAT) winds from ISS.

HP
User avatar
bobc
Posts: 933
Joined: Mon Nov 15, 2010 5:57 pm

Re: inconsistent colour handling with wind barbs

Post by bobc »

Hi HP -

Thanks for the info. I picked up some RapidScat level 2B ocean wind vectors netCDF data and verified that this has all the same problems as ASCAT data. It's good to know that the problems aren't limited to just ASCAT.

Thanks again -
Bob
Post Reply