McIDAS-V Support Forums

Support and discussion of the McIDAS-V software package
Forum HomeMcIDAS-V Home
It is currently 13 Jul 2020, 02:35

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Local servers don't work and I see accounting errors
PostPosted: 10 Oct 2014, 20:27 
Site Admin
User avatar

Joined: 18 Dec 2008, 21:31
Posts: 84
Several users have reported problems using local servers in McIDAS-V. In version 1.4, if there is any problem connecting to local servers, a generic error message appears saying:

Could not connect to dataset “xxxx” on server “localhost:8112”.
Dataset may require ADDE accounting information

In a future stable release, this error message will be better tailored to point towards the actual problem. However, here are some common causes of this error, and potential solutions:

    1. A firewall could be blocking port 8112. This is the first port that the local servers try connecting to. Verify that this port is open on your machine.
    2. There could be a permissions problem. Verify that you, as a user, have full permissions to both your McIDAS-V directory as well as the directory storing the data for the local dataset.
    3. McIDAS-V may have been installed as Administrator (Windows) or as root (UNIX). Verify that McIDAS-V was both installed and run as your own user.
    4. Navigate to the ADDE Data Manager (Tools > Manage ADDE Datasets) and look for the text at the bottom of the window. This will either say ‘Local servers are running’ or ‘Local servers have been stopped’. If local servers are not running, in the ADDE Data Manager, try starting local servers (Local Servers > Start Local Servers).
    5. Verify that nothing in your McIDAS-V directory (such as a preference or a plugin) has caused any problems. To do this, through a command prompt or terminal, cd to your McIDAS-V-System directory, and start up McIDAS-V using the –userpath flag to point towards a non-existent directory. For example:
    runMcV –userpath C:/Users/my_user/testDir
    - This will start up McIDAS-V as if it were the first time McIDAS-V was run. Set up your local dataset again, and try connecting to it. If this solves the problem, please send an email to the Help Desk through the Help > Show Support Request Form menu item in the Main Display window.
    6. Verify that there are no cygwin1.dll files on your machine other than in your McIDAS-V-System directory. Do a search of your system to verify this. If there are other cygwin1.dll files, test that McIDAS-V isn’t trying to use them by temporarily changing their names (this includes changing the ‘.dll’ at the end of the filename). Once this is done, restart your machine and try McIDAS-V again.

After going through the above list, if you are still having problems connecting to local servers, please send an email to the Help Desk through the Help > Show Support Request Form menu item in the Main Display window.

Additionally, if running 64bit Debian or Ubuntu operating systems, an error can appear at startup and local servers will not work if the ia32-libs package is not installed on the workstation. The ia32-libs are the 32bit libraries that 32bit applications need to execute on a 64bit system.

Thanks –
McIDAS User Services


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group