Page 1 of 1

Can't Make Preview Image

Posted: Thu Feb 09, 2012 4:33 pm
by joleenf

I was certain that someone else has reported this, but cannot find a forum post or inquiry. When I am loading a unzipped bundle (.mcv), I occasionally find that the bundle does not seem to know where to get the data. At that point, the error "Can't make preview image" appears numerous time. It is not an endless loop, but can be quite long. If I have the patience to click "ok" enough times to get past the problem, the resulting data which is displayed in the bundle is often nothing, at the very best, less than what I had intended to save.


Re: Can't Make Preview Image

Posted: Wed Feb 15, 2012 8:42 pm
by jayh
Hi Joleen-

I couldn't find an inquiry or forum post that matches what you are seeing. I tried your bundle out and see the same behavior. This inquiry has been written...

Thanks, Jay

Re: Can't Make Preview Image

Posted: Tue May 07, 2019 9:55 am
by rriosalido

I still have the same problem, when I load a bundle (.mcv), the message "Can't make preview image" appears repeatedly. After pressing OK all the times the images are finally loaded, this prevents it from being updated automatically.

I'm using McIDAS-V 1.8, I've checked the bundle and it appears clearly the lines:

<method name="put">

on lines 356 and 713



Re: Can't Make Preview Image

Posted: Tue May 07, 2019 4:32 pm
by bobc
Hi Ricardo,

I think I figured out what's going on here. Looking at your log file, it appears that the imagery data was originally loaded as an absolute time that no longer exists on the server. For example, from the ADDE URLs, McIDAS-V originally attempts to load the following from

GE-WV: May 5th 2019; 00:10:28Z
GE-WV: May 5th 2019; 06:10:28Z
GE-IR: May 5th 2019; 00:10:28Z
GE-IR: May 5th 2019; 06:10:28Z

When loading the bundle, McIDAS-V looks to first load in the GFS model data, followed by the imagery listed above. These "Cannot Create Preview Image" errors may be a bit of a misnomer since an actual preview image isn't created, but the root of the problem is that these times aren't on the server. Inquiry 1929 covers not showing all of these preview image errors and showing a single error that the data isn't available on the server.

Once you click through these preview image errors, the gridded data displays and sets the "Presion nivel mar hPa" layer as the time driver. The satellite layers are then displayed since the layers were set to match the times of the gridded data, and these times (being more recent) are on the server.

It seems like you basically did everything correctly when creating this bundle except that the imagery data source didn't work as expected since it used absolute times.

To fix things, I'd load your bundle and click through the preview image layers until you get everything displayed. Then, do the following:
  1. Remove the imagery layers from your display
  2. From the Field Selector, right-click on each of the imagery data sources and remove them
  3. From the Satellite>Imagery chooser, connect to
  4. Choose "GE-IR" as the Image Type
  5. From the Relative times tab, click the "Match Time Driver" checkbox at the bottom of the tab
  6. Click Add Source
  7. From the Field Selector, optionally change the name of the Data Source (as you did in your bundle) and enable polling
  8. Display your data
  9. Repeat steps 4 - 8 with "GE-WV" Image Type
  10. Save the bundle again. Note that you can save it to a new name on the chance that something goes wrong

Using the "Match Time Driver" checkbox in the Satellite>Imagery chooser loads in the imagery data sources with only the time(s) that match the time driver in your display (the gridded data), so it's almost guaranteed that the data will exist on the server. Please let me know if you have any other questions or concerns about this.

Bob Carp
McIDAS Help Desk

Re: Can't Make Preview Image

Posted: Wed May 08, 2019 12:20 pm
by rriosalido
Thank you very much Bob, I will follow your instructions and report back to you.



Re: Can't Make Preview Image

Posted: Fri May 10, 2019 11:03 am
by rriosalido
Thank you very much Bob, the problem has been solved.